# After deploy the portworx operator iam getting the error like below in openshift 4.10

**URL:** https://forums.portworx.com/t/after-deploy-the-portworx-operator-iam-getting-the-error-like-below-in-openshift-4-10/1480
**Category:** Portworx Install
**Tags:** install, operator
**Created:** [November 2, 2022, 4:59pm UTC](https://forums.portworx.com/t/after-deploy-the-portworx-operator-iam-getting-the-error-like-below-in-openshift-4-10/1480 "2022-11-02T16:59:40Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![vijaycse15\_jakkam](https://yyz2.discourse-cdn.com/flex030/user_avatar/forums.portworx.com/vijaycse15_jakkam/32/633_2.png) [@vijaycse15\_jakkam](https://forums.portworx.com/u/vijaycse15_jakkam)
#### Post date: [November 2, 2022, 4:59pm UTC](https://forums.portworx.com/t/after-deploy-the-portworx-operator-iam-getting-the-error-like-below-in-openshift-4-10/1480/1 "2022-11-02T16:59:40Z")

</div>

[root@ip-10-0-134-217 /]# pxctl status  
PX stopped working 8.1s ago. Last status: Could not init boot manager (error=“The IAM account does not have sufficient privileges to perform operation: list EBS volumes (DescribeVolumes). Consult Portworx documentation for details on providing necessary AWS privileges during installation.”)

List of last known failures:

Type ID Resource Severity Count LastSeen FirstSeen Description  
NODE NodeStartFailure ip-10-0-134-217.ec2.internal ALARM 1 Nov 2 16:58:39 UTC 2022 Nov 2 16:58:39 UTC 2022 Failed to start Portworx: The IAM account does not have sufficient privileges to perform operation: list EBS volumes (DescribeVolumes). Consult Portworx documentation for details on providing necessary AWS privileges during installation.  
[root@ip-10-0-134-217 /]#

---

<div class="post-metadata">

### Author: ![vijaycse15\_jakkam](https://yyz2.discourse-cdn.com/flex030/user_avatar/forums.portworx.com/vijaycse15_jakkam/32/633_2.png) [@vijaycse15\_jakkam](https://forums.portworx.com/u/vijaycse15_jakkam)
#### Post date: [November 2, 2022, 5:00pm UTC](https://forums.portworx.com/t/after-deploy-the-portworx-operator-iam-getting-the-error-like-below-in-openshift-4-10/1480/2 "2022-11-02T17:00:00Z")

</div>

# SOURCE: [https://install.portworx.com/?operator=true&mc=false&b=true&kd=type%3Dgp2%2Csize%3D150&s="type%3Dgp2%2Csize%3D150"&c=px-cluster-2943f5e5-d2e2-43ba-b970-96d50a2f5525&osft=true&stork=true&csi=true&mon=true&tel=false&st=k8s&promop=true](https://install.portworx.com/?operator=true&mc=false&b=true&kd=type%3Dgp2%2Csize%3D150&s=%22type%3Dgp2%2Csize%3D150%22&c=px-cluster-2943f5e5-d2e2-43ba-b970-96d50a2f5525&osft=true&stork=true&csi=true&mon=true&tel=false&st=k8s&promop=true)

kind: StorageCluster  
apiVersion: [core.libopenstorage.org/v1](http://core.libopenstorage.org/v1)  
metadata:  
name: px-cluster-2943f5e5-d2e2-43ba-b970-96d50a2f5525  
namespace: kube-system  
annotations:  
[portworx.io/install-source:](http://portworx.io/install-source:) “[https://install.portworx.com/?operator=true&mc=false&b=true&kd=type%3Dgp2%2Csize%3D150&s=“type%3Dgp2%2Csize%3D150”&c=px-cluster-2943f5e5-d2e2-43ba-b970-96d50a2f5525&osft=true&stork=true&csi=true&mon=true&tel=false&st=k8s&promop=true](https://install.portworx.com/?operator=true&mc=false&b=true&kd=type%3Dgp2%2Csize%3D150&s=%22type%3Dgp2%2Csize%3D150%22&c=px-cluster-2943f5e5-d2e2-43ba-b970-96d50a2f5525&osft=true&stork=true&csi=true&mon=true&tel=false&st=k8s&promop=true)”  
[portworx.io/is-openshift:](http://portworx.io/is-openshift:) “true”  
spec:  
image: portworx/oci-monitor:2.11.4  
imagePullPolicy: Always  
kvdb:  
internal: true  
cloudStorage:  
deviceSpecs:  
- type=gp2,size=150  
kvdbDeviceSpec: type=gp2,size=150  
secretsProvider: k8s  
stork:  
enabled: true  
args:  
webhook-controller: “true”  
autopilot:  
enabled: true  
csi:  
enabled: true  
monitoring:  
prometheus:  
enabled: true  
exportMetrics: true

---

<div class="post-metadata">

### Author: ![vijaycse15\_jakkam](https://yyz2.discourse-cdn.com/flex030/user_avatar/forums.portworx.com/vijaycse15_jakkam/32/633_2.png) [@vijaycse15\_jakkam](https://forums.portworx.com/u/vijaycse15_jakkam)
#### Post date: [November 2, 2022, 5:03pm UTC](https://forums.portworx.com/t/after-deploy-the-portworx-operator-iam-getting-the-error-like-below-in-openshift-4-10/1480/3 "2022-11-02T17:03:59Z")

</div>

NAME READY STATUS RESTARTS AGE  
autopilot-7bf67fbc76-bwgjz 1/1 Running 0 134m  
portworx-api-bsn9t 0/1 Running 0 134m  
portworx-api-cfztn 0/1 Running 0 134m  
portworx-api-hwnt4 0/1 Running 0 134m  
portworx-api-jkbwz 0/1 Running 0 134m  
portworx-api-l6z46 0/1 Running 0 134m  
portworx-api-z298d 0/1 Running 0 134m  
portworx-api-z68js 0/1 Running 0 134m

i have configured iam rule in aws also as per below

 ![MicrosoftTeams-image (1)](https://canada1.discourse-cdn.com/flex030/uploads/portworx1/original/1X/7c80b08c08dfc695214e7305923cfa99c9598a96.png)
