Portworx Essential Operator 2.9 install on either OKD 4.7 or 4.8 - cluster pods not ready


Trying to evaluate Portworx. Generated simple vSphere targeted (did try PureStorage but same results - so trying the simplest at the moment) spec is like this (tried every version 2.6 though 2.9 on several clean OKD clusters): kubectl apply -f ‘https://install.portworx.com/2.9?operator=true&mc=false&kbver=&oem=esse&user=a762523e-7959-11ec-b486-7287e80c8e63&b=true&kd=type%3Dthin%2Csize%3D32&vsp=true&vc=“type%3Dthin%2Csize%3D1000”&c=px-cluster-4d633e36-355b-46ba-84a8-d25cfae7c6e8&osft=true&stork=true&csi=true&mon=true&tel=false&st=k8s&promop=true

Pods being created and started. All cluster and api node pods are in not ready state. Last entries in logs are:

time="2022-01-31T19:09:11Z" level=warning msg="Could not retrieve PX node status" error="Get dial tcp connect: connection refused"`Preformatted text`

Log from one of the nodes is attached.

Did try steps in “Add the Portworx service accounts to the privileged security context” (even though they are for DaemonSet (_https://docs.portworx.com/portworx-install-with-kubernetes/openshift/daemonset/1-prepare/) with the same result.

What am I am missing?
Thank you!

Looks like logs didn’t make it in the original message. Here is link - Logs from one of the pods