Portworx on rke etcd issue

I’m trying to get portworx to start on an on-prem vmware centos7 rke cluster with 3 control plane nodes (one of which is also the etcd node) and 2 worker nodes. I’ve followed the directions to set up px-kvdb-auth from the etcd certs. the error I get is portworx[151057]: time=“2021-03-31T19:59:43Z” level=error msg=“Could not init boot manager” error=“error in obtaining etcd version: Get https://x.x.x.x:2379/version: x509: certificate signed by unknown authority” Any help is appreciated!

there 2 important points : as per the prerequisite you need to have 3 worker nodes Prerequisites

and secondly, you need to create the secrets using your etcd certs. can you please confirm that you create the secrets as mentioned below steps?

This block will guide you on how to give your etcd certificates to Portworx using Kubernetes Secrets. This is the recommended way of providing etcd certificates, as the certificates will be automatically available to the new nodes joining the cluster. If you are not providing any of the above files, leave it blank.

#### Create Kubernetes secret

Copy all your etcd certificates and key in a directory `kvdb-secrets/` to create a Kubernetes secret from it. Make sure the file names match the default names given above.

# ls -1 etcd-secrets/

Use `kubectl` to create the secret named `px-kvdb-auth` from the above files:

# kubectl -n kube-system create secret generic px-kvdb-auth --from-file=kvdb-secrets/

Notice that the secret has 3 keys `kvdb-ca.crt` , `kvdb.crt` and `kvdb.key` , corresponding to file names in the `kvdb-secrets` folder. We will use these keys in the Portworx spec file to reference the certificates.

# kubectl -n kube-system describe secret px-kvdb-auth
Name:         px-kvdb-auth
Namespace:    kube-system
Labels:       <none>
Annotations:  <none>

Type:  Opaque

kvdb-ca.crt:      1679 bytes
kvdb.crt:  1680 bytes
kvdb.key:  414  bytes

Once the above secret is created, proceed to the next steps. ```

I’ve have had to change course away from the enterprise trial version and switch to essential version and I’m having trouble with this set up as well.

I have a 5 node rke cluster with 2 master nodes running control plane and etcd.
I have 3 worker nodes that each have extra drives attached. drive sdb is 50 GB and drive sdc is 128 GB on all 3 worker nodes.

On one of the worker nodes the px-cluster pod started up fine.
On the other 2 worker nodes I get this error: “Error loading identity: Could not find any storage device(s) with PX footprint.” func=setNodeInfo package=boot

If you are reusing the same worker nodes. tried to install the portworx before on those failing worker nodes. Run this below commands on the failure nodes and check the portworx status.

systemctl stop portworx
/opt/pwx/bin/pxctl sv nw --all
systemctl start portworx

If not, list the drives by lsblk and blkid . let me know the outcome. thanks

Failed to find PX storage devices. Please re-run the command with -s param.
Errors found while decommissioning license leases: exit status 1Wiped node successfully.

That worked! Thanks.
BUT What was exactly wiped and from where?

good to know. it wiped only provided porworx drive. if you tried to install the px before multiple time, it might have picked up this drives and created the filesystem on it. Now we deleted and reinitialized the portworx on those drive and node. . that’s why it was not picked up initially .