Portworx failing on OpenShift 4.10 on IBM Cloud

I am trying to deploy Portworx Enterprise on and OpenShift 4.10 cluster on IBM Cloud, deployed through the IBM Cloud catalog tile. It is a brand new cluster, and are no issues on with the cluster, but Portworx fails to deploy successfully. As a result, Portworx is unusable on the cluster.

Portworx pods on the cluster never enter a healthy state, and Portworx never becomes available on the cluster, no matter how long you wait. There are errors in the logs and events on the pod, including:

  1. “insmod: WARNING: could not insert module /tmp/btrfs.all.el8.kos/x86_64/4.18.0-372.9.1.el8.x86_64/fs/btrfs/btrfs.ko: Unknown symbol in module. Check dmesg for more information.”
  2. “Failed to execute patch fs for kernel 4.18.0-372.26.1.el8_6.x86_64, exiting…”
  3. “Readiness probe failed: HTTP probe failed with statuscode: 503”

Steps to recreate:

  1. Create an OpenShift 4.10 VPC cluster. (Have tried both RHEL7 and RHEL8 workers, and the result is the same in both cases).
  2. Create a Portworx Enterprise service instance from the IBM Cloud Catalog, pointed at this cluster. Select the internal KVDM database option. I have tried with all 3 different versions of Portworx available in the IBM Cloud offering, and all end up with the same result (Portworx 2.9, 2.10, and 2.11).
  3. The Portworx service instance shown in the IBM Cloud resource list shows that it deployed successfully. However, the Portworx deployment & pods inside of the cluster never become healthy. All pods in the portworx and portworx-api DaemonSets never enter a healthy/ready state, and both events and logs show failures.

Is there a workaround that can be used to get Portworx healthy on the cluster?

This implies the kernel is not compatible with the Portworx version. I am assuming you are trying to install Portworx 2.11.4 with Cloud Drives option. We will get PWX version updated (within 48 hours).

I’m trying to deploy via the IBM Cloud catalog: Portworx Enterprise - IBM Cloud
Into managed OpenShift via IBM Cloud

@SriniEmm any idea on a timeline when a new version has been pushed?

Just confirmed. This is working again on IBM Cloud.