Unable to connect to plugin: /run/docker/plugins/pxd.sock/Plugin.Activate:


I’m tested on portworx my dev swarm , after a brief i’ve decided to uninstall it, was not easy to find how to do it, but finally at least there are no px processes, but if i do a “docker volume ls” in any machine of the swarm y keep getting the message in the subject, in the docker log, in every machine on the swarm, how can i get rid of this message ?

@Ignacio_J_Ortega_Lop : https://2.1.docs.portworx.com/install-with-other/docker/standalone/#uninstalling-the-px-oci-bundle

Check the Uninstalling the PX OCI bundle and let me know if this worked or not.

I tried that recipe you pointed, but the error persisted…

Looks like the clean-up did not go well. Execute the following on all the swarm nodes and let us know.

systemctl stop portworx
rm /etc/systemd/system/portworx.service -f
rm /etc/systemd/system/multi-user.target.wants/portworx.service -f
systemctl daemon-reload
/opt/pwx/bin/pxctl service node-wipe --all
rm -rf /etc/pwx
umount /opt/pwx/oci
rm -rf /opt/pwx
rmmod px -f

Finally we had to get rid of the socket in /run/docker/plugins/pxd.sock manually and restart docker